Uniface Client Server App Development

uniface software, uniface technology, uniface project, uniface forum

Archive for October, 2012

[U-L] MSS Ticks (stripping them off)

Dear Uniface Users,

I would like some help about how to strip off the ticks from a combined
uniface date and time field.

I think that this is necessary because Microsoft SQL server stores time to
1/300th of a second. I have a non uniface application inserting data and a
uniface application updating it. If there are and non zero ticks in the time
I get the following error :

[Microsoft][ODBC SQL Server Driver]Datetime field overflow

Does anyone have an eligant way of removing them quickly. (or working around
this problem).

Also are there any reference infomation about this.

Please let me know.

Thanks & regards,

Neil Whitson
Australian Tourist Commission
http://australia.com

**********************************************************************
The information in this e-mail is confidential and is intended
only for the use of the above named recipient. In certain
cases it it also legally priviledged. If you are not the intended
recipient, any dissemination, distribution or copying of this
e-mail is strictly prohibited. If you have received this e-mail
in error, please advise immediately by return e-mail.
Unless the contrary is stated, the contents of this message
do not necessarily represent the views or position of the
Australian Tourist Commission.  The Australian Tourist
Commission does not represent or warrant that this message
or any attachments to it are free from viruses or defects.
**********************************************************************

.
posted by admin in Uncategorized and have Comment (1)

[U-L] OCX – Progress Bar

Hi everyone,

Has anyone tried to implement the Microsoft Progress Bar 6.0(SP4) or
v5(SP2)? I have tried the Compuware OCX test form but I’ve not been able
to make it work yet.

Any help would be greatly appreciated.

Regards
Pal
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

posted by admin in Uncategorized and have No Comments

Uniface 7206 plus Oracle 8.0.6

Dear all,

I am testing our application, prior to sending it out to a customer who
*really* wants this specific combination of uniface & oracle, and I have
run into some problems :

Using ASV to connect to an Oracle 8.0.6.2 instance I get error 10038 :
network is gone.

The client logfile shows that the PSV connection opened ok, followed by
a read of the uobj & udesc on the server. Then when the form is opened
(on the server) the crash occurs.

The system has been compiled using Uniface 7205, the U4.0 driver and
works perfectly against an Oracle 8.0.5 instance.
I am told that 8,0,6 is simply a bug fix to 8.0.5 so I shouldn’t (?)
expect too much trouble there (or should I ?)

Does anyone have any ideas, or have you got this combination working, If
so, I’d be pleased to hear from you.

Thanks in advance.

Regards, Norman.

————————————————————————
——–
Norman Dunbar           EMail:  NDun…@LynxFinancialSystems.co.uk
Database/Unix administrator     Phone:  0113 289 6265
Lynx Financial Systems Ltd.     Fax:    0113 201 7265
                        URL:    http://www.LynxFinancialSystems.com
————————————————————————
——–

posted by admin in Uncategorized and have Comment (1)

Non-modal form question

Hi all,

When calling a non-modal form from the startup shell, is there any way to
keep program flow within that form. I have tried running it /sync to no
avail.

This is needed because our menu system has a re-login option which is placed
in a while loop. The startup shell will loop until a logout variable becomes
set.

The problem is that once the menu form is activated and displayed, program
flow returns to the startup shell and processing continues.

Any ideas?


Martin

posted by admin in Uncategorized and have Comment (1)

Re: [U-L] Uniface 7206 plus Oracle 8.0.6

Norman,

You usually have to compile FRM’s, SVC’s and RPT’s for each new release of
Uniface.

I suspect this is your problem, especially since it occurs as soon as the
form is opened.

I suggest that you copy your repository into a ‘temporary’ database and
compile it there, rather than run 7206 against your 7205 repository, since
there may be no going back….

Uniface Support, Consultants, Version Control
http://march-hare.com
http://march-hare.com.au

Sincerely yours,

Arthur Barrett
Senior Uniface Consultant

- — -

> —–Original Message—–
> From:      Norman Dunbar [SMTP:ndun...@lynxfinancialsystems.co.uk]
> Sent:      Wednesday, January 24, 2001 3:59 AM
> To:        unifac…@uug.org
> Subject:   [U-L] Uniface 7206 plus Oracle 8.0.6

> Dear all,

> I am testing our application, prior to sending it out to a customer who
> *really* wants this specific combination of uniface & oracle, and I have
> run into some problems :

> Using ASV to connect to an Oracle 8.0.6.2 instance I get error 10038 :
> network is gone.

> The client logfile shows that the PSV connection opened ok, followed by
> a read of the uobj & udesc on the server. Then when the form is opened
> (on the server) the crash occurs.

> The system has been compiled using Uniface 7205, the U4.0 driver and
> works perfectly against an Oracle 8.0.5 instance.
> I am told that 8,0,6 is simply a bug fix to 8.0.5 so I shouldn’t (?)
> expect too much trouble there (or should I ?)

> Does anyone have any ideas, or have you got this combination working, If
> so, I’d be pleased to hear from you.

> Thanks in advance.

> Regards, Norman.

> ————————————————————————
> ——–
> Norman Dunbar              EMail:  NDun…@LynxFinancialSystems.co.uk
> Database/Unix administrator        Phone:  0113 289 6265
> Lynx Financial Systems Ltd.        Fax:    0113 201 7265
>                    URL:    http://www.LynxFinancialSystems.com
> ————————————————————————
> ——–

posted by admin in Uncategorized and have No Comments

Re: [U-L] Non-modal form question

Hi Martin
Use a small trick

instead of
activate "my_non_modal_form".()
activate "next_form"
write
activate "non-modal_form".() ; the last line in the shell
in the trigger <menu> of the shell
if ($compnentname="my_non_modal_form")
  activate "next_form"
endif
and in next_form put macro "^menu" when you satisfy with your logical condition and when you exit the <next_form>
I used this trick and it works fine
Baruch

———————————
Do You Yahoo!?
Yahoo! Auctions – Buy the things you want at great prices.

posted by admin in Uncategorized and have No Comments

Set the WebBrowser Zoom property from Visual Basic 6.0 application.

I’am currently making a Visial
Basic 6.0 program that use the WebBrowser control
(Microsoft Internet Control) in order to
visualize HTML documents. I want to give to the
customer the possibility to set the value of the
Zoom, as it is possible to make from the "View
Menu " of Internet Explorer, to the voice "Text
size", where it is possible to choose between 5
various types of sectings: largest, larger,
medium, smaller, smallest. To implement this
functionality, I am using this instruction:
WebBrowser.ExecWB OLECMDID_ZOOM,
OLECMDEXECOPT_DONTPROMPTUSER, pvaIn
where ExecWB is the command which allow the
WebBrowser to set the Zoom, according to the
value (0 to 4) passed from pvaIn parameter.
However this instruction does not change the
value of the Zoom.
I ask to know if this instruction is not
supported from VB or if it is wrong the way in which
I have written it.

Thanks in Advance,
Agnelli Ilaria.

Sent via Deja.com
http://www.deja.com/

posted by admin in Uncategorized and have No Comments

[U-L] MSS Ticks (stripping them off)

Dear Uniface Users,

I would like some help about how to strip off the ticks from a combined
uniface date and time field.

I think that this is necessary because Microsoft SQL server stores time to
1/300th of a second. I have a non uniface application inserting data and a
uniface application updating it. If there are and non zero ticks in the time
I get the following error :

[Microsoft][ODBC SQL Server Driver]Datetime field overflow

Does anyone have an eligant way of removing them quickly. (or working around
this problem).

Also are there any reference infomation about this.

Please let me know.

Thanks & regards,

Neil Whitson
Australian Tourist Commission
http://australia.com

**********************************************************************
The information in this e-mail is confidential and is intended
only for the use of the above named recipient. In certain
cases it it also legally priviledged. If you are not the intended
recipient, any dissemination, distribution or copying of this
e-mail is strictly prohibited. If you have received this e-mail
in error, please advise immediately by return e-mail.
Unless the contrary is stated, the contents of this message
do not necessarily represent the views or position of the
Australian Tourist Commission.  The Australian Tourist
Commission does not represent or warrant that this message
or any attachments to it are free from viruses or defects.
**********************************************************************

posted by admin in Uncategorized and have Comment (1)

[U-L] OCX – Progress Bar

Hi everyone,

Has anyone tried to implement the Microsoft Progress Bar 6.0(SP4) or
v5(SP2)? I have tried the Compuware OCX test form but I’ve not been able
to make it work yet.

Any help would be greatly appreciated.

Regards
Pal
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

posted by admin in Uncategorized and have No Comments

Uniface 7206 plus Oracle 8.0.6

Dear all,

I am testing our application, prior to sending it out to a customer who
*really* wants this specific combination of uniface & oracle, and I have
run into some problems :

Using ASV to connect to an Oracle 8.0.6.2 instance I get error 10038 :
network is gone.

The client logfile shows that the PSV connection opened ok, followed by
a read of the uobj & udesc on the server. Then when the form is opened
(on the server) the crash occurs.

The system has been compiled using Uniface 7205, the U4.0 driver and
works perfectly against an Oracle 8.0.5 instance.
I am told that 8,0,6 is simply a bug fix to 8.0.5 so I shouldn’t (?)
expect too much trouble there (or should I ?)

Does anyone have any ideas, or have you got this combination working, If
so, I’d be pleased to hear from you.

Thanks in advance.

Regards, Norman.

————————————————————————
——–
Norman Dunbar           EMail:  NDun…@LynxFinancialSystems.co.uk
Database/Unix administrator     Phone:  0113 289 6265
Lynx Financial Systems Ltd.     Fax:    0113 201 7265
                        URL:    http://www.LynxFinancialSystems.com
————————————————————————
——–

posted by admin in Uncategorized and have Comment (1)